#32
Updated
CVS as of 11/05/2005
Some Important Comments
  • Standard Build Updated
    Optimized Build Updated
    Inferno Build Updated
    Standard FRED2 Updated
    Optimized FRED2 Updated
    Inferno FRED2 Updated
    The file 'FadeIconS-freighterCW.ani' must go into your data/interface folder inorder to use FRED2 debug builds to work with retail content.

#33
Using the 20051101 inferno build, i`ll try the updated ver. (20051105)

All in all, i`d say fs2open has come a long way.. Each new build improves, the future of fs2open has a lot to offer, and it can only get better..

(edit) Oops... Got a page cannot be found from the 20051105 updates, i`ll try again later.
Who am I? Take 3 guesses, and the first 2 don`t count.

#41
Updated
CVS as of 11/07/2005
Some Important Comments
  • Standard Build Updated
    Optimized Build Updated
    Inferno Build Updated
    Standard FRED2 Updated
    Optimized FRED2 Updated
    Inferno FRED2 Updated
    The file 'FadeIconS-freighterCW.ani' must go into your data/interface folder inorder to use FRED2 debug builds to work with retail content.

#43
They still have individual arrival cues. Look in the mission file. But putting ships in a wing also sets the cues to false, which is why there was no "setting to false" dialog - they had been set to false already.

In summary, all these problems you're reporting are symptoms of the fact that initial docking is not set up to handle wings. It wasn't in retail FS2 (if you had a wing with just one ship - try it) and it's not in SCP. That's an entirely separate issue from muliple ship docking. Initial docking and wings both have their own separate way of creating ships.

Just don't dock wings of ships to a carrier and you should be fine. Alternatively, create a single Mantis report titled "Initial ship docking does not work for wings" and it'll be taken care of. I don't know how long it will take, though, because as I said it's an entirely separate issue.
OK, I gave this a test under Red's 2005/11/05 build, and it crashed during mission load. I had the arrival cues of the wings docked set to "true" and I got the following error message in debug:

Assert: (pobjp->flags & P_SF_DOCK_LEADER)
File: c:\fs2_open\code\mission\missionparse.cpp
Line: 2123

Now, I changed them to "false" manually and the debug CTD'd, but the release build worked. Unfortunately, some of the docked raiders were cast off as the carriership arrived, and then self-destructed. Also, the number of raiders that were cast off wasn't constant. In the same mission, repeated a few times, it could cast off 4 of the 6 raiders, while another time it may cast off only 3.
The Trivial Psychic Strikes Again!

#44
Double post.

I'm also getting a few annoying bugs, which seem to have been in there since 10/30. Basically, something's weird with the WIP Drakh Mothership I'm testing out. It's 42 KM long, but if the ship is more than about 65 KM away, it will fail to render. It may be the clipping distance, or it may be someting new introduced that affects very large models. The 10/29 build doesn't suffer from this. Also, for some reason that ship will fail to generate a warpin effect (even though the box for that is unchecked in FRED), and won't perform any warpin deceleration. Anyone know what could be accounting for this?
The Trivial Psychic Strikes Again!

#45
The file 'FadeIconS-freighterCW.ani' must go into your data/interface folder inorder to use FRED2 debug builds to work with retail content.[/list]
Er... any idea why?
Er, well I will email you later about that. It is not Code related believe it or not.
Locked

Who is online

Users browsing this forum: No registered users and 2 guests

cron